DPD Label announcement issues
Incident Report for Returnless v1
Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 15:02 CET
Monitoring
The service appears to be restored. We are now monitoring the results.
Posted Nov 21, 2023 - 13:32 CET
Identified
The issue was confirmed to be on the carrier's side. The carrier is working as fast as possible to correct the problem, but at the moment it is not yet possible to say exactly when the normal service will be restored.

Further updates will follow as soon as available.
Posted Nov 21, 2023 - 11:46 CET
Investigating
DPD is currently experiencing issues related to label announcement. We are investigating this issue with the carrier.
Posted Nov 21, 2023 - 11:35 CET
This incident affected: Carriers (DPD).