Sendcloud degraded performance
Incident Report for Returnless v1
Resolved
The issue has been resolved and all customers have received a valid return label by email.
Posted Jul 13, 2021 - 17:59 CEST
Monitoring
The issue seems to be resolved, we are monitoring the results and will send a return label by email to all impacted customers.
Posted Jul 13, 2021 - 15:16 CEST
Investigating
Because of an issue with the SendCloud platform, we're experiencing issues with creating shipping labels through SendCloud, DHL and DPD.

We are in contact with SendCloud to monitor the situation.
Posted Jul 13, 2021 - 14:43 CEST
This incident affected: Carriers (PostNL, bPost, DHL, DPD).