(External) Mollie platform: Major disruption
Incident Report for Returnless v1
Resolved
Between 03:04 and 03:17 CET, ING experienced a disruption affecting iDEAL payments.

You may notice a decline in successful iDEAL payments during this timeframe as consumers were unable to complete iDEAL payments using ING.

The issue has been resolved and payment processing has been restored.
Posted Feb 19, 2024 - 16:21 CET
Investigating
Our payment service provider Mollie has identified a disruption affecting their API.
You may see a decline in successful payments as connections to their API may intermittently time out.

We will provide updates as they become available.
Posted Feb 19, 2024 - 15:59 CET
This incident affected: Payments (iDeal, Bancontact, Credit Card, Apple Pay).