iDeal: partial disruption
Incident Report for Returnless v1
Resolved
This incident has been resolved.
Posted Nov 06, 2020 - 18:00 CET
Monitoring
A fix was rolled out at 16:58 CET. The iDEAL conversion has returned to the usual levels.

Mollie continues monitoring the situation.
Posted Nov 06, 2020 - 17:11 CET
Investigating
Our payment provider Mollie is seeing a lower conversion on iDEAL payments since 15:51 CEST. Therefore, it's possible that customers are currently experiencing issues with iDEAL payments.

They are investigating this issue.
Posted Nov 06, 2020 - 17:09 CET
This incident affected: Payments (iDeal).