Update of Return portal
Incident Report for Returnless v1
Resolved
We are currently deploying an update on our platform to improve performance to the return platform. We will finish this update in 5 minutes.
Posted Sep 23, 2020 - 23:11 CEST