External - Mollie platform disruption
Incident Report for Returnless v1
Resolved
This incident has been resolved.
Posted Feb 05, 2024 - 18:14 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2024 - 17:49 CET
Investigating
We're currently unable to connect to our payment service provider Mollie.
They have identified a disruption affecting their API.

We will provide updates as they become available.
Posted Feb 05, 2024 - 17:23 CET
This incident affected: Payments (iDeal, Bancontact, Credit Card, Apple Pay).