DHL NL and BE - label announcement issues
Incident Report for Returnless v1
Resolved
This incident has been resolved.
Posted Oct 20, 2023 - 15:21 CEST
Identified
DHL is currently experiencing some issues with the API.

Updates will follow as soon as the API is working again.
Posted Oct 20, 2023 - 09:51 CEST
This incident affected: Carriers (DHL).